SUCCEED FASTER  |  www.WeGetAroundNetwork.com
WGAN-TV: Now Playing
Next on WGAN-TV Live at 5
One Order  |  One Quote  |  One Contact
Book Multiple GLOBAL Commercial Locations
  • ✔  As-Builts
  • ✔  Construction Progress
  • ✔  Facillities Management
Last 24 Hours: 967 Unique Visitors
8,337 WGAN Members in 146 Countries
Last 30 Days: 58,342 Page Views | 21,572 Unique Visitors | 75 New Members
We Get Around Network Forum
Capture AppProblems

New Matterport app version 2.0 is completely broken on Android17482

wildcatdave71 private msg quote post Address this user
My phone auto updated to version 2.0 of the matterport app. I'm using a Samsung Galaxy s20. The app is now completely unusable. Every single shot... processing takes anywhere from 1 to 2 minutes and half the time it just disappears and stops processing, sometimes the app closes, sometimes it goes back to the page that shows all of your jobs. Previously processing would take less than 10 seconds and I could shoot another shot while it was processing in the background.

I will often then reshoot that same spot and that one will disappear as well. Occasionally both of them will then show up later stacked on top of each other. At this point it's unusable and I use this nearly every day to shoot houses and large commercial properties for clients.

Luckily I have a tablet that I've also installed the app on previously that I used for some jobs. For some reason even though Auto update was set in the Play store it did not update and still has version 1.46 of the app. I was able to use that today to do two shoots with normal fast processing and everything worked properly.

I have contacted support and they said they know about this issue, they're working on a fix. They said there is no way to roll back to the older version as once the app is updated that is the only version available. If any of you are experiencing this and do not have an alternate older version installed you are basically stuck until they fix this.

I cannot believe this wasn't tested. The new app was only out for a day and I contacted them and they said they knew about this already, which means there has been a flood of people getting a hold of them in less than 24 hours from release. This is completely unprofessional for a piece of software that is used for people's livelihood.

It's quite obvious how faulty it is, they should have experienced this repetitively during testing, assuming they did any testing at all. I switched from Ricoh tours because of their inability to have stable software and it looks like Matterport can't do any better. I love when companies release new versions with all these features that apparently everyone's asking for (I don't really know anyone that needed or asked for these new features). And then they stuff the software full of new stuff and then break the basic functionality.

If you're experiencing this issue please pester their support team and let them know how ridiculous an untested update is for such a huge number of users.

Just to test it I also loaded the new version on a different tablet that has a different Android operating system and it also does not work on that one. So it is not just my phone, the app is completely broken and they should have known this if they even spent 10 minutes testing.

If I could switch to another company I immediately would as I don't believe in supporting a company that thinks it's okay to release software onto professional clients that's absolute trash.
Post 1 IP   flag post
Shakoure private msg quote post Address this user
@wildcatdave71 ...Any word from Matterport?
Post 2 IP   flag post
WGAN
Forum
Founder
Atlanta, Georgia
DanSmigrod private msg quote post Address this user
@wildcatdave71

Do you have an updated from Matterport Support?

Thanks,

Dan
Post 3 IP   flag post
wildcatdave71 private msg quote post Address this user
No update at all. Everyday or so I get an automated reply, but nothing from the actual support team. They really should roll back the version even if they have to call it version 2.01 and put the old code back in.
Post 4 IP   flag post
WGAN
Forum
Founder
Atlanta, Georgia
DanSmigrod private msg quote post Address this user
@wildcatdave71

Given how important this issue is, it would be nice if Matterport got back to you sooner.

Dan
Post 5 IP   flag post
wildcatdave71 private msg quote post Address this user
So I have some good news... On my phone I uninstalled the new version 2.0 of the Matterport app. Then I rebooted the phone. Then reinstalled the Matterport app. I did a test shoot on a small condo and had no issues at all. In fact I would say the processing and wait time between photos was notably shorter than it was with the previous version.

I believe they did an update on the Android version on the Google Play store. It now lists version 2.0.1 build 922 when you open the matterport app. I'm pretty sure previously it was 2.0.0.

Anyway for now it's working fine. I will continue to bring my tablet, that still has version 1.4.6, with me in case there is an issue with this newest version. I have 10 big photo shoots of Gold's gyms in California - cannot have any hiccups. Those shoots are over 200 images to create the spaces!
Post 6 IP   flag post
Grant private msg quote post Address this user
The app on my iPad just automatically updated tonight... I'm trimming out tours from today and its very laggy.. So much so that I popped back to the forum and left a comment!! Hey MatterPeeps!
Post 7 IP   flag post
wildcatdave71 private msg quote post Address this user
THIS IS IMPORTANT, I FORGOT TO MENTION, BUT I'M SURE MOST OF YOU KNOW IT. IF YOU UNINSTALL THE APP FROM YOUR PHONE OR TABLET IT WILL DELETE ALL OF THE JOBS ON THAT DEVICE. SO MAKE SURE YOU HAVE UPLOADED ANY JOB YOU WANT BEFORE YOU UNINSTALL THE APP.
Post 8 IP   flag post
wildcatdave71 private msg quote post Address this user
I just got confirmation from Matterport that the update posted two days ago is in fact the fix, everything should be fine for everyone now at least on Android
Post 9 IP   flag post
93711 9 9
Log in or sign up to compose a reply.